Wednesday, August 22, 2012

Wamp Server vs IIS 7 - The Sequel

Looks like I ain't done with the Great Satan Server IIS 7. Was a third component I just had to disable, after IIS7 returned and tried to evict Wamp from the PC.
control panel > Administrative Tools > Services.msc > World Wide Publishing service
Thank you to the one who posted this on
Am I going to go through this angina every time Microbrains does an update?
gave a compromise solution for letting IIS keep localhost and reassigning Wamp to localhost:8080 (set Apache to listen to 8080. Well, I don't care if IIS wants 8080. It can have it, but I need Wamp to keep port 80. Thankfully the perfect solution, for me anyway, was found at
I went into IIS's default website, thence to edit bindings and gave IIS the @#$%^& port 8080. Restarted WWPS and now both web servers work fine. Hopefully no further Microbrains update will screw it up again.

Monday, August 20, 2012

Hmm. This sounds familiar

Rosaura showed me this post someone made concerning their periodontal situation. Sounds awfully familiar to what I'm facing, or was told I'm facing.

Dead Tracks is a Done Deal

Got the new slider installed for the internal site links.
As it exists now, The Dead Tracks is pretty much a done deal, just awaiting fresh content, if I can dig it up from my, er, archives, wherever those archives might be buried.

Streetlights Facebook Page Has Launched

Jeff's Streetlights and Highways-Site on Facebook

Finally got this page going. So far, I've uploaded my old bridge photos. Will be uploading my old parkway content next.

New Streetlight Site under construction at:

Refurbished Dead Tracks website, still on Angelfire, but sans the awful banner ads, at

Sunday, August 19, 2012

Rounding Image Corner the Hard Way

Finally got an epiphany after pulling my hair out trying to figure out why my Dead Tracks images' corners weren't rounding when my other sites' images were.
Was using the same @#$%^& code, the @#$%^&* CSS. GRRRRRRR!
Finally realized I had those images set for 3% padding elsewhere in the CSS.
Padding big NO-NO with border-radius. Border-radius no like padding!
Changed the @#$%^&* padding to margin and now everything is joyful in CSS land.

Wednesday, August 15, 2012

Fixing Wamp Server Not Starting Issue

Has your Wamp, Xampp, or other such Apache web server suddenly refused to start?
Hmmmm? Installed any Microsoft Visual Studio or SQL items lately?
I was saved this evening from tearing my hair out by this post on:

Basically, whatever I'd recently installed activated Microsoft IIS, the arch rival web server to all these Apache run devils.
But, I prefer to work with the devil I know, and did not wish to move all my www directories over to the IIS root. I like playing with Apache settings, even when they come close to putting me in an insane asylum.
Thanks to whoever wrote the article linked to above, I knew what to do to fix this - go into Administrative Tools from Control Panel, and basically tell IIS to go to hell (That means I turned it off, for all you gentle folk).
Then to services and do the same to Web Deployment Agent Service. And so much for that tag team.

Of course, the first usual suspect when this issue comes up is Skype, which by default like port 80, the port required by Wamp/Apache. That's also an easy fix. In Skype's connections settings you can uncheck the box where Skype uses that port.

This issue occurred on a Windows 7 64 bit PC.

NOTE: See update posted 8-23-2012. The above was not the end all solution.